All Corsa Forum banner
loss of power
1-8 of 8 Results
  1. Mechanical, Exhaust & Performance/Tuning
    Hi can someone please help. My 52 plate 1.0L corsa has no power when trying to accelerate and judders as if it's getting power then loosing it again. It was working fine until I put petrol in from a different place to usual. The engine management light came on briefly 6 or 7 hours after the...
  2. Mechanical, Exhaust & Performance/Tuning
    Hi Folks, myself and my partner bought a corsa in July 2012 last year. The car was second hand previous owner was disabled and car was registered for disabled tax. Got a full service for the car back in November. Car is only drove through town twice a day to travel to work and various...
  3. Mechanical, Exhaust & Performance/Tuning
    My battery died on Wednesday night, the AA came out and replaced it for me and everything was fine, until I drove to work the next morning. The engine light starting flashing and when I pressed the accelerator there was no power. Thankfully I managed to car share that day, so when I returned...
  4. Ice, Electrics & Lighting
    Hi Everyone, I have recently purchased an Opel Corsa B as my first car from a friend. I try to do as much repairing as I can myself as I'm a student studying Electrical and Electronic Engineer and I love playing around and fixing things on the car. I have been sifting through the forums on...
  5. Mechanical, Exhaust & Performance/Tuning
    recently after a trip to dublin (about 200 miles all round) the car has started becoming sluggish and has lost pretty much all power. i think its started to miss fire as well. i had the head skimmed and a whole new gasket set put in about 1000 miles ago, new back box, new leads and sparks, new...
  6. Mechanical, Exhaust & Performance/Tuning
    Today whilst driving at around 45 mph, my EML came on and i slowly began losing speed. When i reached around 20mph i eventually gained some more speed. Since, my car has felt extremely sluggish and was been struggling to accelerate, especially when going uphill. Any suggestions as to what the...
  7. Mechanical, Exhaust & Performance/Tuning
    Hi guys. i have a problem with my corsa 1.0l life 55 plate. when im driving its fine for the first 5 mins or so then i accelerate to 4000ish revs then change to second gear and the engine management light flashes and the car judders and its hard to accelerate. i had a full service about 2000...
  8. Mechanical, Exhaust & Performance/Tuning
    Hi :) I own a 1.2 Merit 93 Yesterday when driving home the Engine Management Light came on for about 15 seconds and then went off for about a minute and then came on for another 15 seconds or so. There was no noticeable difference in the engine, so i continued on the motorway at 60 with no...
1-8 of 8 Results
Top