All Corsa Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Hello bugman yes it is an update and I've found out the same so I'm going to take the turbo off clean it and check the wastegate and from looking around and getting good advice it seams to work so do you or anyone know of any pics or videos on how to remove and clean would be a big help thank you very much and all the best mate
 

·
Banned
Joined
·
147 Posts
Hi.I have never done this job.But from a quick search on you tube there are several clips on replacing the actuator on various cars which give an idea of where to start.
If it were me I would as a first step leave the turbo on the car then disconnect the vacuum actuator arm.Its clear how to do this from the videos.

Then give the gate arm a good joggle in the hope this frees it up,with maybe a squirt of brake cleaner if there is somewhere obvious to squirt it.(is there no end to my ignorance?) This may be enough to sort it. Its free, so its worth a try.
It could be the vacuum actuator that is the problem. Unfortunately they are usually the wrong side of 40 quid so you need to be sure. good luck
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
Just an update it's all done and I've got power love it .. It was the wastegate it was stuck so I did the mr muscle trick and didn't have to take the turbo off and after 2 hours it was all sorted so thanks for all the help and I hope it helps others
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top