All Corsa Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi,my son has a 2000 corsa c 1.2sxi, the airbag light is on (mot fail) the garage tried re-setting it with there system but it could not link with the airbag, only engine management, i then had a diagnostics specialist come out to the car but he also could not connect either of his two systems, after checking fuses etc he says he does not think there is a live feed going to the control unit( behind center column) is there an additional fuse to number 32 or a relay that might cause this?
Also if anybody knows what colour the feed wire is at the connector block that would be really helpfull.
Thanks, Mark
 

·
Registered
Joined
·
2,887 Posts
If you haven't got a wireing diagram and confident with electrics do not mess with it as it could cause airbag deployment
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Thanks for the replies so far, i cant say which system the diagnostics guy was using but both the garages and his have been used for corsa c airbag diagnostics, he says there is no power going to the airbag control unit and therefore it cannot be read, all other systems were readable ( abs, engine management, etc, etc)
The 5amp fuse in the main fuse box is ok, is there another fuse or relay that could cause a loss of feed to the unit?
If anybody knows which is the live feed to the airbag control unit on this year, (colour code)have found the feed on a 53 plate but all the wiring is coloured differently, it would be helpful so that we can check if 12v volts is coming in to the connector and therefore the fault is in the connector block?
Thanks again, Mark.
 

·
Premium Member
Joined
·
8,351 Posts
dude, it has to be read by tech 2 at a main dealer, no other scantool can read the airbag system on corsa c's, not even solus. DO NOT GO LOOKING FOR 12V FEEDS. you will detonate an airbag.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Are the main dealers the only ones with tech 2 ?? or is it possible that tech 2 was being used by the diagnostics guy?
Does anyone know if there is a relay or additional fuse for the airbag system that would cut the feed to the control unit?
 

·
Premium Member
Joined
·
8,351 Posts
the only access to tech 2 is at main dealer. there is one fuse iirc.
 
  • Like
Reactions: markb

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Thanks Rob, that's what i needed to know, no more time wasted looking for some mystery fuse etc , i didn't want to waste my sons money on taking the car to the dealer to be told they can't read it but here is the bill!
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
Vauxhall have now looked at car, they say they cannot connect to the diagnostic port for the following reasons:

Short circuit to voltage between diagnostic link terminal 8 and A63 airbag control unit terminal 30

Circuit interruption between A63 air bag control unit terminal 7 and ground

Circuit interuption between F32 fuse output contact and Airbag control unit terminal 5

Circuit interuption between K50 Relay Terminal 15
Socket terminal 87
and F32 fuse input contact

Any ideas anybody ??
 

·
Banned
Joined
·
8,758 Posts
quick fix for an MOT? take the bulb out.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #13
Thanks, but i really want to fix the fault as this is my sons first car and i would like the airbags to be working if he were to have an accident.

with regards the short circuit between diagnostic link terminal 8 and airbag ecu terminal 30, there is 4.3 volts when ecu is connected and ignition on, 0 volts if ignition off, airbag ecu disconnected or fuse 32 removed. ( when vauxhall did there initial checks they suggested that there shouldn't be any voltage here)

The earth is ok at terminal 7 on airbag ecu

There is 12 volts at airbag ecu terminal 5 so i assume that the connection between the relay and fuse 32 and fuse 32 to airbag ecu is ok

Apart from the 12 volts to terminal 5 there is no voltage to any of the airbag ecu terminals when disconnected from the airbag ecu.
Would this suggest that the fault is in the airbag ecu ??

Any advice would be greatly appreciated.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #15
The guy at vauxhall suggested that as a possibility, would the reason there is no voltage there when disconnected be because it has no earth via terminal 7?
 

·
Banned
Joined
·
8,758 Posts
My first car didnt even have an airbag. My parents dont love me :(
 

·
Registered
Joined
·
9 Posts
Discussion Starter #18 (Edited)
Sorry maybe i didn't describe it very well, with the connector disconnected i used terminal 7 on the connector as my earth and checked all other terminals on the block, the only voltage was at terminal 5 (12 volts) as it should be. if there was damage to the loom shouldn't the voltage still show up at terminal 30 ?
When the airbag control unit is reconnected the voltage shows up at terminal 30 airbag module and terminal 5 diagnostic port which are linked via a brown and white wire which apparently should have no voltage ? this being the reason tech 2 cannot link.
Does this suggest that the stray voltage is being picked up from the airbag module? or am i just misunderstanding how it all works??
Thanks for being patient, as i am sure you can tell this is all quite new to me!!
 
1 - 18 of 18 Posts
Top