All Corsa Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Just had new clutch fitted on my Corsa B 1.0 litre. First thing I did was open the bonnet and check to see how much adjustment was on the cable. I'm an untrusting soul

I could have cried becuase there is no adjustment left on the rod and this is a new clutch. The cable is also new.

It changes gear perfectly although the biting point is high. Garage is having it back in friday - the manager is not happy with his technician - he seems pretty genuine.

Any idea what they could have done wrong? I'm pretty sure the clutch has been changed - the arm that goes into the gearbox must be moving more than it should

Regards
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #3 ·
not sure

Arm looks pretty good - a mate seems to think the may have fitted the wrong release bearing or fitted a wrong cable. They should not have touched the cable though.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #5 ·
could be cable may have been replaced

When I had trouble with the clutch I replaced the cable just in case the old one had stretched. Made no difference so the cable on the car had only done 8 miles. Maybe as you suggest they might have replaced this when they did the clutch but used the wrong cable. The Garage Manager did not like how far the arm was moving (the one which goes into the gearbox)
 

·
Registered
Joined
·
2,887 Posts
What brand clutch have they used i have this with mine atm i fitted a poor quality clutch last year and it slipped from new and bite was high it was worse than the gm one i removed that was pretty much on the rivets
 
1 - 6 of 6 Posts
Top