All Corsa Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Sorry for starting a new post - in middle of exams at the moment so don't really have the time to go through all the previous posts with similar problems.

My corsa life 1.0 2002 cut out twice yesterday at traffic lights but managed to get it running again within a few minutes. Felt as though I had stalled but I hadn't! Did it again today when I was parking in my drive and managed to catch what lights appeared on the dash as it cut out and they were the oil light, EPS light and battery light. Again it started up again after about a minute. Just put some redex in the petrol tank in hope that could work?

My car hit 80,000 miles yesterday and has a full service history with the last service in march. Had a new battery last November.

Any help would be greatly appreciated!!
 

·
Registered
Joined
·
9,410 Posts
Those light are normal when an engine loses rpm.

If it's only doing it at idle / off throttle the first thing I'd do is to give the throttle body a clean. The crankcase fumes are fed through the throttle body so as the miles clock up oily deposits can make the throttle body sticky. A quick spray with carb cleaner is worth doing - let us know how it goes after that.

The best thing I've found is Quicksilver Powetune which is made for outboards - ebay is the easiest place unless you have a boat chandlers nearby.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top