All Corsa Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
[/QUOTE]Hi all,
I have got a corsa 1.2 sxi 2005. Engine running lumpy. checked with a fault reader and says Mass air flow circuit. Ive change it and no difference. was told that it could be a bad earth and try re earth it to body. anyone one know what colour the earth wire is please as there is 5 wires on the plug. Yellow, green,blue,red, white.
 

·
Registered
Joined
·
1,480 Posts
Hi there, see if we can work this out, my Haynes manual says thos

1 brown and blue signal or earth
2 red and white live for ambient air temperature sensor
3 brown earth for ambient air temperature sensor
4 red and white suspect 5 volt reference wire
5 brown and green signal or earth

so earth is either pin 1 or 5, my guess is pin 5, brown and green, these colours seem different to yours, vauxhall usually use Brown for earth, white for ignition...So if you test the wires with a multi tester, i think the air temp sensor live will be 12 volts, that's pin 2, pin one seems to go to earth, should be brown, so discard those two, pin 4 should have 5 volts on, ignition on, which leaves you 1 and 5, well what you can do is with the plug on put you meter to pins 1 and 5 in turn, one should show negative, an earth, the other should be 0.5 volts at idle and 4+ volts at full throttle snap what ever...hopefully its working well enough to tell you which is which, all the 3 wires on the MAF sensor go to the ECU....i guess one of them earths through the ECU....good luck...if that sensor voltage goes from 0.5 to 4+ volts then the sensor is working anyway....good luck from Fred in Essex.

Hi all,
I have got a corsa 1.2 sxi 2005. Engine running lumpy. checked with a fault reader and says Mass air flow circuit. Ive change it and no difference. was told that it could be a bad earth and try re earth it to body. anyone one know what colour the earth wire is please as there is 5 wires on the plug. Yellow, green,blue,red, white.[/QUOTE]
 
1 - 2 of 2 Posts
Top