All Corsa Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi I purchased a 1.4 sxi 2011 corsa for my daughter and I need advice.
1st error code P1071 so had lambda & mass airflow sensors changed, then another code that lead to new rocker cover, plus air flow cleaned through, but now have new error something to do with cylinder 4?
The mechanic has been fantastic, but now feels beat???
The car is idling erratically and running like poo, please can anyone give me advice, apart from blowing it up...... Thanks Tracy x :palm:
 

·
Registered
Joined
·
1,479 Posts
PS Tracy, a poor idle can be caused by the EGR valve being stuck open or an air leak....Fred.

Hi I purchased a 1.4 sxi 2011 corsa for my daughter and I need advice.
1st error code P1071 so had lambda & mass airflow sensors changed, then another code that lead to new rocker cover, plus air flow cleaned through, but now have new error something to do with cylinder 4?
The mechanic has been fantastic, but now feels beat???
The car is idling erratically and running like poo, please can anyone give me advice, apart from blowing it up...... Thanks Tracy x :palm:
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
PS Tracy, a poor idle can be caused by the EGR valve being stuck open or an air leak....Fred.
Hi Fred

Got car back, change coil pack and plugs, which cleared error and car was running fine, not long after leaving mechanic the idling started fluctuating again when coming to a stop and stationary.

rang mechanic and he said to wait for engine management light to come on and we can detect what error code it is.

After all that has been changed, both sensors, rocker cover, coil & plugs and cleaned, do you think it could be the EGR or if a air leak where do you think that would be?

Thank you in advance for your kind help? Tracy x
 

·
Registered
Joined
·
1,479 Posts
Hi Tracy, well i would hardly think that sort of problem could be caused by plugs and coils, sensors maybe...yes it could be an air leak or egr valve sticking, i'm inclined to agree with mechanic wait till the light comes on, or do a code test anyway see if there is anything there, i would start it up let it idle and have a look under the bonnet see if you can hear any air leaks, i'm assuming the brakes work ok and the pedal isn't hard, that would indicate brake servo leak, in other words an air leak...if you hear any hissing you can locate it with just a bottle of plain water...just squirt on it...

The egr valve if it is like mine is on the passengers side of the engine around the top, its connected between the exhaust and the inlet manifold, has a plug on with about 4 to 6 wires, round cylindrical, that needs to be taken off, and there is a plunger on the inside that can stick, you have to spray it with brake cleaner or carb cleaner some kind of solvent, and work the plunger in and out,,,if it lets air through at idle it can cause your problem...hope that helps....have a good day from Fred.

Hi Fred

Got car back, change coil pack and plugs, which cleared error and car was running fine, not long after leaving mechanic the idling started fluctuating again when coming to a stop and stationary.

rang mechanic and he said to wait for engine management light to come on and we can detect what error code it is.

After all that has been changed, both sensors, rocker cover, coil & plugs and cleaned, do you think it could be the EGR or if a air leak where do you think that would be?

Thank you in advance for your kind help? Tracy x
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Thanks Fred,
you've been very helpful, greatly appreciate it, once all is working I will let forum know the outcome and hopefully it my help someone else in the same situation.
Regards
Tracy x
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top