All Corsa Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi,
I have a 55 plate Corsa. On a morning my car did start's up fine, when I stopped and turned the engine off and say go into a shop when I came back 5-20 mins later and started the car up the engine started up but then cut out straight away and it has done this for 2-3 months maybe. I did at around the same time get an engine light on my car which when diagnosed was a P300 fault but I just got this cleared and was told it was a mis-fire.

In the last 11-7 days on a morning my car takes a 1-2 seconds longer to start up which is not a lot but I have noticed the difference and still have the above issue but no engine light on my car dashboard. Also I can smell petrol quite strongly when I get out of my car could this be a problem? Or is this normal? Any advice on the issues?

Thanks
 

·
Banned
Joined
·
885 Posts
It is worth checking again for fault codes, the smell of petrol, if not due to a leak, could be due to an ignition fault, in which case,what you are smelling may be unburned fuel in the exhaust.

The way that you describe the engine starting, and then cutting out within a second or two, COULD indicate an immobiliser problem. It might be worth trying your spare ignition key, as there is always the chance that the problem is down to the transponder in the key.

Regards.

P.S.
Welcome to the Forum by the way.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top