All Corsa Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello,
I have a corsa 1.4 petrol 2005 automatic with the air con not working, when you press the a/c button the revs drop abit and you almost think the compressor has cut in but it does not!(compressor will cut in and work very intermittently, when it does cut in the air con works fine but that is hardly ever!)

I have had a new a/c pressure switch and had the a/c regassed and it is still the same, the problem I am having is that the engine ecu pin 7 is not sending out an earth to the relay to pull in the a/c clutch! has anyone had this fault before? im 90% sure that the engine ecu must have an internal fault and this is why its not giving the earth signal to pull in the a/c relay! would an engine ecu be a common fault??

I cant figure out from the auto data wiring diagram how the engine ecu know when the a/c button inside the car is being turned on or off, if it cant see the on/off signal I guess it would not earth the relay to pull in the a/c clutch!
I would like to check this first before I write off the engine ecu due to the cost!
If any one can help or had the correct wiring diagram I would be really grateful!
Thanks sammas
 

·
Banned
Joined
·
885 Posts
Welcome to the Forum.

I have to agree with you, why do these diagrams' always show you everything in great detail that you don't want to know, but seem to always leave out the bit that you need?

Looking at my diagram (and using a bit of logic), I can't see why the engine ECU would need to know about the AC.
If you are quite sure that the system still has the correct amount of gas in there, it might be worthwhile fitting a TEMPORARY feed and earth to the compressor clutch to see if it is working correctly. DO NOT do this if you have any doubts about it having sufficient gas, as that is the purpose of the pressure switch - to disengage the clutch in order to protect the compressor, should it run short of gas.

Of course, ECUs can be faulty, but in my experience, rarely are to blame for most problems.

Regards.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for your reply!
I have traced the fault to be that the engine ecu pin 7 is not earthing the a/c relay!
if I earth out the relay the clutch pulls in and the a/c operates perfect!
I think where it is bolted on the engine it has got too hot and damaged the ecu poss one of the soldered joints inside! I have tested every other option so I have posted the engine ecu off to get it tested and repaired for £195 +vat so fingers crossed it will fix the problem!
 

·
Registered
Joined
·
23 Posts
Hi there,

Double check that the switch in the aircon control panel isn't faulty. I have had a lot of these give trouble- they engage the circuitry but don't transmit enough current to engage the clutch: kinda kicks in and out. You said it was intermittent which also sounds about right.

The earth pin will only feed if signal is received to the ecu. Instead of replacing the entire control panel (switch not available separately!) I normally tap into the wires and run an external switch to save my clients money!

Good luck- hope it helps!
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top