All Corsa Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello,
I have a corsa 1.4 petrol 2005 automatic with the air con not working, when you press the a/c button the revs drop abit and you almost think the compressor has cut in but it does not!(compressor will cut in and work very intermittently, when it does cut in the air con works fine but that is hardly ever!)

I have had a new a/c pressure switch and had the a/c regassed and it is still the same, the problem I am having is that the engine ecu pin 7 is not sending out an earth to the relay to pull in the a/c clutch! has anyone had this fault before? im 90% sure that the engine ecu must have an internal fault and this is why its not giving the earth signal to pull in the a/c relay! would an engine ecu be a common fault??

I cant figure out from the auto data wiring diagram how the engine ecu know when the a/c button inside the car is being turned on or off, if it cant see the on/off signal I guess it would not earth the relay to pull in the a/c clutch!
I would like to check this first before I write off the engine ecu due to the cost!
If any one can help or had the correct wiring diagram I would be really grateful!
Thanks sammas
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for your reply!
I have traced the fault to be that the engine ecu pin 7 is not earthing the a/c relay!
if I earth out the relay the clutch pulls in and the a/c operates perfect!
I think where it is bolted on the engine it has got too hot and damaged the ecu poss one of the soldered joints inside! I have tested every other option so I have posted the engine ecu off to get it tested and repaired for £195 +vat so fingers crossed it will fix the problem!
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top