All Corsa Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi Guys,

So my car is going in the garage 2moro to get the heating looked at. All blowers when turned on full heat only blow out cold air. I was having a read of previous posts, I don't have any water in foot well. Have checked anti-freeze/coolant and this is at correct level. Have also checked the engine oil for signs of head gasket going but no signs of this - i'm looking to see if oil is mayo looking is this right?

Any other ideas on things I could check so I have a rough idea what it could be. I have £250 in cash set aside lol just hoping won't be anything major and cost anymore than this :confused:

Thanks!
 

·
Registered
Joined
·
24,002 Posts
Mayo, does not always mean head gasket. Cars that do short journeys will naturally get this.

Does the temperature of the car get hot fast?
Hs it been like this, sineceyou purhased car?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Mayo, does not always mean head gasket. Cars that do short journeys will naturally get this.

Does the temperature of the car get hot fast?
Hs it been like this, sineceyou purhased car?
I purchased the car in the summer and to be honest can't remember if I checked the heaters? :S erm have only really noticed it with the cold weather when went to turn them on and cold air coming through. Temperature of the car I would say doesn't have any problem at heating up. Gauge gets to the middle point almost straight away yes.
 

·
Registered
Joined
·
9,410 Posts
Sounds like the thermostat is OK. So it's probably either a blocked heater matrix or one of the controls has come adrift behind the panel - if someone has been replacing bulbs for example.
 

·
Registered
Joined
·
9,410 Posts
If it's a control come adrift it's a small job with probably pennies for parts.

If it's the matrix is clogged it could be expensive. The matrix itself is a silly price and it's a pain to get and and replace. I got someone sorted with a 2nd hand one but it still cost £250 fitted. The matrix usually only clogs if coolant changes have been neglected - so check the state of the coolant. If it's rusty looking that might be the issue.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top