All Corsa Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Alright! Had an endless search through past threads but if I've missed a post covering this already then you all have my apologies for the spam haha..

Essentially I've got a 52 plate C 1.2 with almost 40k on. Only had the car a couple of months and recently noticed that if I've got the window down and give it some welly I can hear what sounds like engine pinking (like a bag of nails being shook) between 2.5 and 4k rpm. Idle is a bit lumpy on a cold engine but sorts itself when warm, oh and the engine only misses when its warmed up, never when cold. The car hesitated for a second on the motorway before giving a surge of power and a couple of times I've had a bit of a flat spot but apart from that it runs sweet.

From what I've read on various sites a misfire should give me a code when the pedal test is done, I don't. Previous owner was a little old lady who never had it above 30 for its entire life, could carbon deposits be causing some pre-ignition? Or could it be a knackered knock sensor which isn't causing the timing to adjust/engine to throw a code..

Anybody who's had a similar problem, chuck your advice in before I get stuck into maf's/coil packs etc haha, much appreciated!
 

·
Banned
Joined
·
885 Posts
Welcome to the Forum.

You could well be right! The problem could be due to carbon deposits or a faulty sensor
Are you sure that it belonged to a little old lady, who never went above 30? Or is that what the salesman told you (joke, by the way - I hope!)

Before you put a lot of effort into sorting it, it might be an idea to try a couple of tanks full of something like Shell V-Power.
Another point worth thinking about, is the servicing. Is it up-to-date? especially, has it got the correct spark plugs in it?

Finally, are you sure that the noise that you are hearing, is in fact 'pinking' and not a mechanical noise?

Regards.
 

·
Banned
Joined
·
147 Posts
Hi. Try a new set of spark plugs even if they are quite new.I once had problems on a nearly new Nova (yes ,that long ago!) with a brand new set of spark plugs.
One was intermittently 'Missing'.

Pinking more often occurs at lower revs under load.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top