All Corsa Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I've swap the engine on my corsa c previous engine think pistons had it! It still ran had no start problems just kicking out blue smoke, so put new engine in now it won't start it's trying, if I pour petrol in the carb ( not sure if that's right) it starts! But then obviously juders and runs out of petrol, towed it to the garage and he said coming up with injecter fault on diagnostics, said could be ECU!
Well I've left it at the garage and he said he'll get an electrician to look tomorrow,
Anyone else think ECU? I've kept the old ecu from previous engine so I know it was fine previous to the engine swap!
Any ideas cuz I'm all out!
 

·
Registered
Joined
·
24,002 Posts
Why doesn't he think the fault is the injector
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Well that's what we are thinking, just took the old injectors out old engine and its got numbers on it my mate reckons ecu will be coded to it could he be right? Should I put old injectors back in??
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Done that already I never changed ECU over, just changed the injectors and injector pump over still nothing! Getting lost now on what it could be, old engine ran fine just blew out blue smoke, no eml on nothing
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top