All Corsa Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
Hi guys, I posted a similar thread yesterday but wanted to start a fresh one with more complete info.

So - a while ago I had the engine management light come on, took it to mechanic, changed sensors, not long later light reappeared, took it back he tried again same thing etc. He advised a few things it could be but said that it was safe to drive for the time being.

A few months later and now my car jerks slightly at speeds over 50mph every so often (maybe once every 5-10 minutes? Not consistently) and seems a tad less powerful, and takes ever so slightly longer to turn on.

I've checked and I have three error codes - P0136 O2 sensor circuit, P0141 O2 sensor heater circuit, P0335 crankshaft position sensor "A" circuit.

I've got a basic ODB2 scanner and iPhone app so I can run some diagnostics etc if anyone could suggest anything that might narrow down the problem. (So far I've checked the error codes and 02 sensors while stationery, sensor 1 fluctuates from 0.8-0.1 every second or so, and sensor 2 stays at 0.46)

Anyone had anything similar? Would these 3 codes indicate any common causes?

PS I have a Corsa D life, 09 plate 1.2 petrol engine.
 

·
Registered
Joined
·
1,480 Posts
Hi there, i have answered this on your other thread, hoping you haven't already changed the parts, or maybe you changed the front lambda instead of the back one...if you have changed all the sensors and still have problem i would disconnect battery for 10 minutes, if that doesn't cure it you may have problems between the sensors and ECU, or even the ECU its self...you might be able to reset something with the OpCom Unit...Fred.

Hi guys, I posted a similar thread yesterday but wanted to start a fresh one with more complete info.

So - a while ago I had the engine management light come on, took it to mechanic, changed sensors, not long later light reappeared, took it back he tried again same thing etc. He advised a few things it could be but said that it was safe to drive for the time being.

A few months later and now my car jerks slightly at speeds over 50mph every so often (maybe once every 5-10 minutes? Not consistently) and seems a tad less powerful, and takes ever so slightly longer to turn on.

I've checked and I have three error codes - P0136 O2 sensor circuit, P0141 O2 sensor heater circuit, P0335 crankshaft position sensor "A" circuit.

I've got a basic ODB2 scanner and iPhone app so I can run some diagnostics etc if anyone could suggest anything that might narrow down the problem. (So far I've checked the error codes and 02 sensors while stationery, sensor 1 fluctuates from 0.8-0.1 every second or so, and sensor 2 stays at 0.46)

Anyone had anything similar? Would these 3 codes indicate any common causes?

PS I have a Corsa D life, 09 plate 1.2 petrol engine.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Hi there, i have answered this on your other thread, hoping you haven't already changed the parts, or maybe you changed the front lambda instead of the back one...if you have changed all the sensors and still have problem i would disconnect battery for 10 minutes, if that doesn't cure it you may have problems between the sensors and ECU, or even the ECU its self...you might be able to reset something with the OpCom Unit...Fred.
Thanks Fred, I'm taking it back to the mechanic who looked at it initially tomorrow, so I'll clarify exactly what he's done previously - I've sent him the error codes already so hopefully he might have a few ideas in advance!
 
1 - 4 of 4 Posts
Top