All Corsa Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Car = 2008 (58 plate) corsa D ecoflex 1.3 cdti

Problem = The car is struggling to get past 3000rpm, it won't go above around 70mph and is really sluggish, it has started to happen in the last few weeks and gotten worse, with a couple of time when accelerating hard, like on the slip road to join the motorway or overtaking it has juddered and the service light flashes on for a second.

History = We had a full service less than 3 months ago, but have done a lot of miles (3000 in the last two months) we have taken it to a garage and they checked the air filter which was clean and replaced all the glowplugs as they looked worn/old but this has not improved or fixed the problem.

Fault code = when doing the pedal test we are getting a fault code that flashes the engine warning light 6-1-2-3. I have been trying to research around this but can't find a diagnosis - we have had the ECU replaced on this car about 2.5 years ago due to water damage (after a heavy snow, apparently a common fault due to the placement) so i was wondering if this is the reason i can't find the 6123 fault code anywhere.

Anyone that can offer any advice or ideas of what it may be is HUGELY APPRECIATED as we are currently abroad (hence the increase in milage) and aside from depending 100% on the car we also don't have a local garage that we can trust. Please help!!

Thanks
 

·
Registered
Joined
·
1,480 Posts
I've never heard of such a number, it could be the throttle position sensor, that is P0123 i have heard you cant do the pedal test on a D only a C, dont know if its true...on a C it normally flashes 10 times first which means 0, after that the numbers are normal. then you put a P in front of it for example P0321.

I would do a test with a code reader, you might be a able to use one of the EOBD reader off ebay, about £10 now...i would think throttle position sensor on pedal or MAF sensor and have a look round for split pipes and air leaks...from Fred in Essex.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Fixed

For anyone else experiencing this problem, we got ours diagnosed by the vauxhall garage and it turned out to be the turbo that needed replacing. The valve gate was stuck on the turbo. We got it fixed with a reconditioned part for about £550.
 
1 - 3 of 3 Posts
Top