All Corsa Forum banner
1 - 20 of 25 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
Hey all :)
Recently bought a Corsa B 1.0 12v, i've been running it for a while with no problems untill a few months ago where it started being hesitant on acceleration.

You'd pull away as normal, then a couple of seconds with no acceleration (which is quite scary when attempting to cross a junction/roundabout) and then all of a sudden it would pull away.
This has only been getting worse ever since. I've been through the forums and read all about various things going wrong and tried them all, im slowly running out of patience and money..:mad:

I've replaced the following:
Catalytic converter and o2 sensor
AFM (thinking it was bad)
Given it a full service (Filters, Plugs and oils)
Engine coolant Temp. sensor
Coil pack (this seemed to work for a couple of days, but the problem is back??)

All of the above had no effect on the situation untill i replaced the coils..?:confused:
Can any one helpp me outt??

Thanks in advance
Stew
 

·
Registered
Joined
·
2,858 Posts
Have you tried re-setting the ecu? Vauxhall ecu's store faults until they are cleared, and so even if you sort the problem out it'll still run rough because it thinks there's a problem. And regardless of what some people on here think, disconnecting the battery overnight does not reset the ecu. You'll have to get it on a code clearer. I recommend that you do that and you might find that one of those things you've replaced has already sorted the problem out. And if it hasn't, at least you'll get a proper fault code that'll tell you exactly what the problem is.
Call around a few garages to see if anyone has the facilities to help you out, and ask for quotes. Most seem to charge about £40 to put it on a code reader, but I finally found a guy who was willing to do it for £15.

Hope this helps you.
 
  • Like
Reactions: corsastu90

·
Registered
Joined
·
51 Posts
Discussion Starter · #3 ·
I haven't tried that yet, i'll give a couple garges near me a quick call and see if they can or not. When i went to quick fit to get my o2 sensor replaced the guy plugeed in a machiene and he said the engine management light went off on its own halfway through the process, so he decided not to carry on with the test.
Even if no fault codes come up should iask him to completely reset the ECU?

Thanks Very much! :D
 

·
Registered
Joined
·
2,858 Posts
The mechanic decided not to look for fault codes because the engine managment light wasn't on? He should be sacked! Even I (and I'll be the first to admit that my mechanical knowledge is minimal) know that you can still have faults even if the management light is off. Try to find a good, honest, independent garage - from my experience their knowledge is always better and they're more ready to help.
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #5 ·
I agree! these are Kwick Fit people were talking about here.. what happened to job professionalism???
Any ways, just back from them now, and it seems to of helped resetting the ECU, All tho there were a couple very minor little hesitations on the way back, not as serious as before however.
If its any extra help i have to give it abit of an extra kick to get a little more revs when im taking off and it seems to help?
As well as while im driving it gets abit hezitant...??
 

·
Registered
Joined
·
2,858 Posts
Did they tell you if any faults came up during the search?
 

·
Registered
Joined
·
5,593 Posts
is the car firing on all cylinders? you said you changing the coil pack helped, maybe try replacing the HT leads too, i mean i dont know much but it could be worth a shot

and yes the mechanic should be sacked, the EML does register until the engine is hot so say yesterday my EML came on if i left it overnight and started the engine this morning the light most probably wouldnt come back on until the engine is hot
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #8 · (Edited)
Nop, They had absolutely no results on it, and going by what you suggested to reset the whole ECU, The problem now isnt as serious as it has been before, hardly noticable. but just down right annoying and intermittent, short of completely buying a new car im rapidly running out of ideas??

And there is no misfire, aswell as my corsa doesnt have HT leads because its a whole coil pack which clips straignht ontop of the plugs..?
 

·
Registered
Joined
·
5,593 Posts
just out of interest does it have a standard air filter on or does it have a cone filter?
 

·
Registered
Joined
·
2,858 Posts
As asked above, is it misfiring? Has the car been standing for a period of time recently? Did the mechanics suggest anything else?
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #11 ·
Everything is standard on the car, bar the wheels, lights and exhaust back box,
I use it near enoiught every day for small things like uni, and general ruinning around
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #13 ·
Its quite alright, no need to worry.. iv been thinking about this for the last couple of weeks and im sure im going grey with it! lol:p

its been suggested maybe a bad batch of fuel..?
Thanks very much for your help any ways Youngsezer:)
 

·
Registered
Joined
·
2,858 Posts
I guess a bad batch of fuel could cause it to run rough. And if it's any consolation it can't be anything major or the code reader should've picked it up. If re-setting the ecu has improved the problem, then maybe the car just needs to settle down again. Try taking it for quite a hard drive and rev it a bit.
 
  • Like
Reactions: corsastu90

·
Registered
Joined
·
51 Posts
Discussion Starter · #16 ·
Yeah i think that might just be the next thing left to do now, asi said its only minor hiccups now, and i supose with a little 1.0 3cyl. you'd notice bad fuel more..?

Im planning wither a long drive down the motorway to southampton and back or into london on a quiet evening some time and just hope either of those work out!
 

·
Registered
Joined
·
15 Posts
have you tried the fuel filter under the car.. a cheap enough part to change

process of elimination....

mine was similar, and it did help'
 

·
Registered
Joined
·
2,858 Posts
have you tried the fuel filter under the car.. a cheap enough part to change

process of elimination....

mine was similar, and it did help'
yeah and check the state of your air filter
 
1 - 20 of 25 Posts
Top