All Corsa Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi,
I have had the car for just over a year and been through about 4 stepper motors! The last two that I have had have been new ones that have gone faulty. I'm just wondering whether anyone has had any simial experiences or know what the problem is.
The last stepper motor that was in the car made the revs too high, it was fine tuned and the idle speed was correct but after accelerating or come to a stop the revs would stay high for a couple of seconds before coming back down.
Two other stepper motors have made the car pulse at 1500 revs and the car pulls/snags everytime you put your foot on the accelerator.
I have had a good stepper motor that worked fine but in the end the motor wore out and the car wouldn't start.
Any ideas would be fantastic, can't work out whether I just keep getting bad stepper motors or there's an underlying problem!
Thanks :)
 

·
Registered
Joined
·
9,410 Posts
It's usual for the ICV to hold the rpm high for a couple of seconds before allowing it to drop, it's designed to keep the drive smoother in slow moving traffic.

If I've read your post right you've had two new motors (the last two used) and two presumably second hand ones - these were the ones that caused the pulsing. Unless they were tested beforehand and known to be good then I'd forget them for the purposes of diagnosing what's going on.

The two new ones seem to have worn out quickly - the question is were they genuine parts or cheap aftermarket bits?

And when you say stepper motors I'm assuming you're fitting replacement motors into your existing ICV - in which case you may find that the ICV itself is worn - eg either poor contacts or worn gears, both of which will cause premature failure of a replacement motor.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Thank you for the advice. After a little bit of tweeking the problem has gone now :)
I have had two new motors, and two old ones (the one that came on the car, and one second hand one from a scrapyard, that worked well until the other day!)
The two new ones were genuine parts, one worked well for a while but the motor died as it was faulty, took it back and they swapped it for this one for me, after a few adjustments this one seems to be working fine now though :)
 
1 - 3 of 3 Posts
Top