All Corsa Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
Vauxhall Corsa Mk1 1996-1997 1.2 Vegas

Hi the clock on my dashboard hasn't worked for years from what I think is someone who's changed/replaced a relay and it hasn't been fixed correctly. I have a feeling the relay's are situated around the engine bay?

If so does anyone know what relay i'd need/where I could find it? 99% Sure it isn't a fuse related problem as I remember my mechanic taking a brief look and telling me my relay is missing.

Advice much appreciated as it not working is beginning to annoy me :thumbs_up:
 

·
Registered
Joined
·
9,928 Posts
Vauxhall Corsa Mk1 1996-1997 1.2 Vegas

Hi the clock on my dashboard hasn't worked for years from what I think is someone who's changed/replaced a relay and it hasn't been fixed correctly. I have a feeling the relay's are situated around the engine bay?

If so does anyone know what relay i'd need/where I could find it? 99% Sure it isn't a fuse related problem as I remember my mechanic taking a brief look and telling me my relay is missing.

Advice much appreciated as it not working is beginning to annoy me :thumbs_up:
There are no relays whatsoever that run to the clock/MFD.
If it isnt a fuse thats causing the issue, the bulbs have probably just blown.
Push the 2 center air vents downward and remove a scren from behind each one.
Now lift the clock away from the dashboard.
Twist each bulb 180 degrees and pull it out.
When both bulbs are out, hold the rear of the clock up to the window, or shine a torch into the holes where the bulbs were.
Whilst doing this, check to see if any digits are being displayed on the clock (they will be feint if they are)
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #3 ·
Nope pretty sure there's nothing being displayed. Any ideas? I haven't thoroughly checked the fuse box as it's a tad awkward to understand but think that'll be the problem?
 

·
Registered
Joined
·
24,002 Posts
Changed bulbs?
 

·
Registered
Joined
·
9,928 Posts
Nope pretty sure there's nothing being displayed. Any ideas? I haven't thoroughly checked the fuse box as it's a tad awkward to understand but think that'll be the problem?
Did you actually do any of what I wrote? Thats the second thing that would be tried by anyone diagnosing the fault - the first thign being them checking the fusebox, the third thing being them replacing the bulbs, fourth is replacing the unit.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #6 ·
No no I have. Bulbs are fine have a feeling it's more complex than that so i'll have a look when I have more time. My car was rebuilt to near perfect about 8-9 years ago. However the electrical mechanic who re-did some of the electrics has repaired them so they work, fully and safely. But they aren't anything like they should be on the default Corsa layout if that makes sense. So the radio was redone, the clock and a few minor things. So I don't think the clock is receiving any power at all, the cable must be at a dead wire or loose end. Shouldn't be too difficult to work out whats going on but I'll just ask a mechanic to do so. Cheers
 
1 - 6 of 6 Posts
Top