All Corsa Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello, im new here and not really sure how to use this site so please excuse me If there is already a thread about this problem.

Basically my car 2003 corsa got rather jumpy when the spanner light turns on but then would turn off and drive fine when the car was heated up, however I got the EGR replaced today by a machanic as I have small siblings that I drop to nursary and want to avoid putting them at risk ect.

However the problem is still that the light is still showing up and this time does not turn off, I took it back just before he closed and he cleared the code (which showed EGR) with his code reader gadget. I then went for a ride and It turned back on however the car does not jump and drives fine unlike before.

Can anyone help me please or give me some ideas to the problem!!??

And sorry if this has been posted before, its my first time asking for help lol :(
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
Hello, just a follow up message, I am getting a newer egr valve, to replace the one I brought over a week ago as that egr valve may be the problem and ill get my refund back.

The spanner light did turn off today but then the emmision light turned on so I am really confused. I did the light test and code read 1405 and then the machanic read the same ( EGR code) which is why I am sending the EGR valve back and getting a new one.

I am really confused and if anyone can help it would be much appreciated.
 

·
Registered
Joined
·
1,480 Posts
Hi i guess you got over this by now, but if you have changed the valve, which i assume is an electronic one with 5 wires on and not the diaphram type, if your still having problems, remove the valve see if its stuck open, push the plunger in and out a few times their spring loaded...the two outer wires are the ones that work the solenoid, the 3 inner ones are the sensor to the ecu if that's any help...from Fred in essex.
 
1 - 3 of 3 Posts
Top