All Corsa Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Hello all,

I've got a 55 plate corsa c twinsport sxi I'm get the engine emission light flash then staying on when I do 60 mph then it goes off when I restart the car. I have had the ecu replaced £££ the cranksensor £££ the spark plugs and the coil pack. I'm pulling my hair out thinking what else can it be. Any advise would be helpful as I haven't got a clue about cars so have to go to a garage and think they just trying to do me over.
 

·
Registered
Joined
·
24,002 Posts
When was it last serviced?


Why was the ecu replaced and coil pack :/
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
The coil pack was 1st replaced as it was loosing power/misfiring but that didn't do anythink so they said it was the ecu so I had that replaced thinking it would sort the problem out but no it hasn't. But the problem only seems to be when I'm on a A road doing 60 or motorway when I'm doing 70. Was last serviced September but I got the car November so that's was the car salesmen said and its stamped in the service book
 

·
Registered
Joined
·
24,002 Posts
Service to some places is "oil and spark plugs" this is a half arsed service.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
I know but would that set off the emissions light. I just don't know what to do next I'm taking it to the garage I had the ecu replaced. But the car is doing me heading at the moment I just have somethink done then the problem comes back and carnt go on the motorway
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #6 ·
And why is it only happening when doing above 60 then the engine emissions light stays on its just wired and I don't know what to do next as I can not go on the motorway
 

·
Registered
Joined
·
9,410 Posts
EGR valve - try cleaning it, if not then blank it off.

The codes won't always point to the EGR being the culprit - you may just be getting a misfire code. It can be tricky to spot, but if you can monitor live engine data whilst on the motorway (ie a passenger monitors it on something like Opcom) then I bet the EGR readings are freezing at higher speeds.
 

·
Registered
Joined
·
2,101 Posts
For that light to be on I would have checked egr valve , lambda sensors and then cat with it being emissions related
 
1 - 8 of 8 Posts
Top