All Corsa Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter #1
my corsa chugs at times as if its lost power but then just starts driving again, the engine managment light also starts flashing now and then. so i phoned vaxhaull up, they say the car needs a computer pluged into it to find out the problem but it will cost me 70 quid. Just checked the oil today and it was badly in need of a re-fill so cars runing fine now,but the engine managment light still flashes after 5-10 mins. plus the oil light never came on it was just the engine management light, anyone else had any problems like this?
 

·
Registered
Joined
·
43 Posts
I had that problem a while ago, when my mate fitted my new stereo somehow one of the little screws had got lodged in with the lighter. So it had blown a fuse.

Check all your fuses to see if they are ok!
 

·
Registered
Joined
·
1,586 Posts
if its chugging and spluttering, chances are that its a sensor, most likley your airflow meter or lambda sensor, do you have an induction kit?
 

·
Registered
Joined
·
1 Posts
if its chugging and spluttering, chances are that its a sensor, most likley your airflow meter or lambda sensor, do you have an induction kit?
arite, mine used to do that a 1.2 16vsxi corsa b, i changed the air flow metre and it was perfect but the ecu light is still on but will it have anything to do with my induction kit which i currently have on m8???????
 

·
Banned
Joined
·
56 Posts
The light being on will need to be reset by Vauxhall...or somebody with the right equipment...like me..

The induction kit will not induce the light to come on on its own...only if it causes problems with the afm which if you have just changed it i doubt it. Take it to vaux or your local garage.
 

·
Registered
Joined
·
447 Posts
sounds to me like a sticky air flow jobby. take it out, give it a spray. happened to my mate. altough i could be wrong
 

·
Premium Member
Joined
·
15,222 Posts
arite, mine used to do that a 1.2 16vsxi corsa b, i changed the air flow metre and it was perfect but the ecu light is still on but will it have anything to do with my induction kit which i currently have on m8???????
To reset your ecu, disconnect the battery for a few hours, then plug it all back in and go for a steady drive.
 

·
Registered
Joined
·
1,183 Posts
My car was doing the same for a bit until I had it fixed. Dont take it too Vauxhall for the diagnosis as you will get it a lot cheaper from your local garage. My car had the same symptons as yours and it turned out to be the ERG (Exhaust Recirculation Gas) valve. The bloke at the garage fixed it in about 3 hours by taking it out and cleaning the valve as it gets stuck open due to a build up of carbon. Cost me about £100, as its a difficult part to get too yourself.
 

·
Premium Member
Joined
·
15,222 Posts
What happened to it?
 
1 - 12 of 12 Posts
Top