All Corsa Forum banner
1 - 20 of 41 Posts

·
Registered
Joined
·
209 Posts
Discussion Starter · #1 ·
Ok so today I've discovered that the head gasket is on its way out I put in 4 litres of oil last week an it's gone. Took out the plugs and they had oil on them to...





Now the car has been fine all day until I took the plugs out... Since then it's like a miss-fire has began all though its fine through the rev range, but when your driving it its got a serious lack of power and acts like its missing.

I know it needs a new coil pack but can't anyone suggest anything or help out I'm at my wits end with it...
 

·
Premium Member
Joined
·
8,351 Posts
thats not oil, thats running rich. replace the plugs, leads and coilpack.
 

·
Registered
Joined
·
24,002 Posts
If they'd burned 4 litres in a week, in sure they'd notice huge cloud of smoke and have shite all over exhaust tip/bumper?


OP, how many miles do you do a week! How do you know you lost 4 litres?


If its because nothing on dipstick that doesn't mean you've lost all of
It
 

·
Registered
Joined
·
209 Posts
Discussion Starter · #7 ·
If it
Loss of oil can be other things than HG - or are there other symptoms as well?
No none

If they'd burned 4 litres in a week, in sure they'd notice huge cloud of smoke and have shite all over exhaust tip/bumper?

OP, how many miles do you do a week! How do you know you lost 4 litres?

If its because nothing on dipstick that doesn't mean you've lost all of
It
Yes there's clouds of white smoke nice with black coming out, exhaust is filthy anyways and bumper Is clean no burns, soot or smoke marks.

Roughly 100 or so a week. I put litres in last weekend as I did oil change abs it was empty earlier.
 

·
Registered
Joined
·
24,002 Posts
I'm
Saying how do you know it lost 4 litres??
These engines only hold just over that iirc?
If you lost 80/90% of that you'd be hearing some noises
 

·
Registered
Joined
·
24,002 Posts
Well I put 4 in last week I've checked the oil at least 12 times today and every time it came back the same.. Plus it was knocking as if it had none
You are not being clear? The dipstick doesn't show all te oil in the engine.
Minimum to max mark is only 1 litre
 

·
Registered
Joined
·
24,002 Posts
Doesn't mean you lost 4 litres then
 

·
Registered
Joined
·
9,410 Posts
I'm not doubting you're losing that much oil - but with no other symptoms then it's not conclusive it's the HG. To be honest with oil loss on that scale there's something seriously amiss, if we could see the car we'd probably be able to track it down PDQ - but over a forum we can only go off the information you provide. So what signs point to the HG being the issue?

When does the engine emit smoke most?

How is the coolant level - and is the coolant showing signs of combustion gases?

Are there any signs of oil leaks around the engine bay?

Have you had the compressions tested?
 

·
Registered
Joined
·
24,002 Posts
This was why I was trying to know how much had gone
 

·
Registered
Joined
·
209 Posts
Discussion Starter · #17 ·
When does the engine emit smoke most?

How is the coolant level - and is the coolant showing signs of combustion gases?

Are there any signs of oil leaks around the engine bay?

Have you had the compressions tested?
When In high revs

Coolant is fine and no signs

No oil leaks that I can see or know of

Yes my mate had two done be for he sold me it and both fine
 

·
Registered
Joined
·
305 Posts
My corsa was pissing oil while driving because of the blown pressure switch which is a pointy thing near the dip stick. It wasn't until looking closeup I saw it was leaking and had no puddles until I refilled oil and it blown outright and did gush out. 6quid and 30seconds to fix. Worth a look. Common thing with corsa. Brought me here.

Sent via phone. Sorry if sucks

I'm not clued up like these guys but ild expect blue smoke of you was burning oil.

When my switch properly broke mine sounded rough despite having full oil as k think it doesn't get around properly if it's broke. Controls pressure
 

·
Registered
Joined
·
209 Posts
Discussion Starter · #20 ·
Yeah but I have a serious lack of power and she's shuddering like a miss however she's not missing, started her his morning and she ran like a dream then all of a sudden she started playing up again.

Just took it to be plugged in for diagnostics cost me £40 :( but hopefully can find out what's wrong
 
1 - 20 of 41 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top