All Corsa Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Sorry if i'm posting this wrong i haven't used the site before.

1.2 2004, 50,000 miles.

A few days ago i noticed a slight vibration as i stopped the car at junctions, which would go on and off. Then yesterday i noticed the temperature gauge got a bit higher than normal, probably to 93, but it didn't concern me too much. Today it got to over 100 (after driving 3 miles), then went back down to about 95 (i was trying to get to my grandparents house in case it wouldn't start again, otherwise would've stopped asap), so i pulled over to let the car cool, then tried again 30 mins later to drive the 2 miles home and after 2 minutes the temperature gauge was back up to 100.

The coolant light isn't on, (haven't had chance to check coolant level its too dark) my heaters were blowing cold air. As i got home i was about to take out the key and then it started to ROAR, it sounded like a plane so i just grabbed the key and ran inside for shelter lol.

All in all from the slight vibration i've only driven around 15 miles. I would've taken it in this morning but with it being good friday everywhere is shut and that's why i've asked on here as i won't get answers until at least tuesday now (not so good friday!!!!!)

I'm only 19/F so a bit clueless but could you give me some advice as to whether its worth repairing or not (scared you're all going to say head gasket lol)
 

·
Registered
Joined
·
1,480 Posts
Well it sounds like you have a cooling system problem, i would suspect water pump and thermostat, i wouldn't keep running the engine too hot it could blow the head gasket and cause even more problems if it boils up, like cracked or warped head...what about the cooling fan does that work, t ought to cut in before 100c i would have thought....good luck from Fred in Essex.
 
1 - 2 of 2 Posts
Top