All Corsa Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
corsa c 1.2 16v hi have got a spark and fuel at rail but wont start if i pour fuel down the throttle body it runs and revs till it runs out. there is presure at the rail just not getting from the rail into the cylinders somehow.
 

·
Registered
Joined
·
23 Posts
Check at your injectors- should be permanent power (with key on) and a negative pulse while cranking. This is what "opens" the injectors. If there is no power, check fuses. If no pulse, check earths. If problem still persists, could be more serious- ECU or a sensor.

Suggest starting with that test and let us know!
 

·
Registered
Joined
·
4 Posts
maybe a long shot but have you had the inlet manifold off for any reason and changed the gasket?

only ask as I have come across your problem in the past when a customer bought a rebuilt engine for his kit car built and ready to go and brought it to use for fitting (it was a YB cossy motor). Any way we couldn't get the ****er to go, plenty compression and flugs were stinking of fuel. anyway the problem was the inlet manifold gasket was the wrong 1 and it was covering the majority of the inlet ports which was the problem in the end, daft I know but we spent days of head scratching and fault finding and in the end I thought the ports had been plugged with rag so popped of the inlet and found it.

long shot I know but good luck
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top