All Corsa Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
Hi All,

I have a 1.4 Twinport, and the top left engine mount was leaking oil.

Looking for replacement, the 1.4 Twinport engine mount is nearly £80!
Other models mounts are only £30.

Well, I thought I am not paying £80 for mount that looks exactly the same as a £30 one so purchased one that was listed as fitting the 1.6 and 1.8 engines.

Took my old mount off, and tried to fit the new mount. Doesn't fit. The mounting point is different.

Looking at it, there is a bolt that goes straight through the mount. So I undone it (A right pain to do)


And the bracket part comes off!


Undone the bracket from the new mount and just swapped my bracket onto the new mount and fitted to the car


Half Price engine mount for 5 minutes work. Result!
 

·
Registered
Joined
·
24,002 Posts
Your mount has oil in it?


:/
 

·
Registered
Joined
·
24,002 Posts
Hydraulic fluid?
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #10 ·
I have just hacked the thing up, and as the pictures will show it IS an OIL FILLED mount.




This one used to judder when pulling away, in our case it was the front engine mount that was knackered.
 

·
Registered
Joined
·
24,002 Posts
Wasn't saying you were wrong mate, was just asking as didn't know corsa used them
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #13 ·
Sorry, that was a copy and paste from the Corsa C Forum. Apologies that it was a bit abrupt. Had a bunch of morons on there telling me that I was wrong.
Next, they will be telling me that my wheels aren't round.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top