All Corsa Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter · #1 ·
Basically story is, I drove down to Bournemouth on Monday, engine management light came on and it refused to let me accelerate quickly or go over about 65mph. Anything over 3000 revs it struggled with and it stalled once or twice. So I got it here and phoned the AA. The man said that it was the air flow sensor so unplugged it and it drove fine, but obviously I can't leave it like this. Today I sourced a replacement sensor and fitted it, started it up and the engine just started hunting (over revving sometimes, and getting very close to stalling other times, whilst just ticking over). Basically it just sounds really unhealthy, it stalls in any gear at random moments, and the engine cannot be left to idle without just sort of dying. Anyone got any advice for me? Called the AA man again who looked and didn't know what to do but tow me to a garage. Thought I'd check here before taking it there tomorrow! Thanks for any help you can give me!!!
 

·
Registered
Joined
·
9,410 Posts
What engine?

Any sign of the engine management light? (If so get the codes read.)

Was the new sensor a Bosch one or an ebay cheapo replica? If so chances are that's your problem. These cheapy ones are more trouble than they are worth.

Trick with airflow meters (as your first AA chap did) is simply to unplug them - at least the car will run. If so then you know it's the AFM that's the problem.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top