All Corsa Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
201 Posts
Discussion Starter · #1 ·
Hi I have a new inlet for my corsa x16xe engine like the mantzel one etc, and I was wondering if anyone has any step by step instruction on fitting them, I have all the blanking plates and all new gaskets etc, but im not sure on what to do with the vacuum hoses, or the hoses that are on the side of the throttle body as the throttle body goes on a completely differnt area? Also isthere any other things to know? Cheers
 

·
Banned
Joined
·
8,758 Posts
Theres a tutorial on cs i believe.
 

·
Banned
Joined
·
8,758 Posts
nope im not a member lol
 

·
Registered
Joined
·
201 Posts
Discussion Starter · #7 ·
Anyone no about the vacuum hoses? Fitted it but its idling abit rough and the throttle is either on or off if you have it in between to hold the revs say at 2000 as bunny hops abit on its own, is the only way I can explain it, any ideas what the problem could be? I no the vacuumlines are not in right but I didn't no if it would make it do that?
 

·
Premium Member
Joined
·
8,351 Posts
airleak
 

·
Registered
Joined
·
24,002 Posts
Put vac hoses on properly :/
 

·
Premium Member
Joined
·
9,047 Posts
Usually when nuts arnt tight enough, the ones at the back are a bitch
 

·
Registered
Joined
·
201 Posts
Discussion Starter · #12 ·
All the bolts a tight, throttle body, inlet etc, double checked them all, I read and followed the instructions but my inlets slightly different to the one he has used mine has two vacuum pipe connectors on the inlet and the brake servo were as his one has one I think it was and the brake servo, and I would put them on right if someone could tell me where they go to.... where would the air be leaking from that badly to make it do that, id hear or feel it but I've felt and listened all over but no joy so far
 

·
Premium Member
Joined
·
9,047 Posts
Is yours a cheap, badly made one by any chance?
 

·
Registered
Joined
·
201 Posts
Discussion Starter · #14 ·
it was quite cheap, bit quite well made id say, all the welds are good, properly laser cut ovals so it matches the inlet and had nothing but good reviews about it, whys that?
 

·
Premium Member
Joined
·
9,047 Posts
I only ask as if it was a cheaply made one, the air leak may of been from the actual unit itself. ie. manufacturing fault
 

·
Registered
Joined
·
201 Posts
Discussion Starter · #16 ·
Finally sorted it, map sensor vacuum was leaking slightly enough to cause a problem but runs perfect now
 
1 - 16 of 16 Posts
Top