All Corsa Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
hi guys, just wondered if someone could help, i have a 04 1l corsa 3 cylinder that wont start, i have checked injectors and spark both fine, replaced crank sensor and 02 sensor on exhaust, no lights flashing to indicate its a key problem and no codes showing on obd, any ideas??? any help would be appreciated
 

·
Registered
Joined
·
1,479 Posts
Hi there i assume it turns over ok...if not check battery and starter etc....then you need to check for a spark at the plugs, i know you said the plugs are fine, but you need to take the coil pack off put a plug in each of the outlets in turn, earth the plug to the cylinder head and crank it over see if you get a spark across the plug..if not it could be coil pack wiring fault ecu etc....

If you have a spark there put it all back together, take the air intake off and squirt a drop of easy start in the air intake while cranking see if it will run on that...if it does you have a fuel problem....if not you might have to think about something mechanical like a blocked exhaust...timing chain jumped a few teeth, miss aligned cam sensor....or some kind of valve piston problem...

But do make sure the Immobilizer is not armed...think a light will stay on or flash on the dash if it is...that might stop the spark or fuel supply....also try pushing the schrader valve core in on the fuel rail see if it squirts out, if not you could have fuel pump problem..that's in the tank...it should give you a 2 second prime when you turn the ignition on...you can hear it....good luck from Fred in Essex.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top