All Corsa Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi there, recently bought a corsa c and I'm really pleased with it. Only thing is when I indicate left, inside it goes really quickly but outside nothing happens on any of the three left hand lights. After a few seconds it may slow down to normal and I get an ordinary flash or two on all three bulbs but then it races off again and I get no lights. This isn't happening on the right, only the left. I replaced all three bulbs but no change. I have read about the indicator relay needing replacing but have not come across these specific symptoms so wanted to take some advice before spending money. Also I don't know anyone else with a corsa to check a known working relay. Any advice would be amazing as the mot is fast approaching!

Cheers,

Nick
 

·
Banned
Joined
·
885 Posts
It sounds as if there is a poor/intermittent electrical connection.
As this affects all three lights on the left hand side, it is at a point common to all three - you could do worse that check that the switch is working properly.

Regards
 

·
Registered
Joined
·
1,479 Posts
Hi Nick well they all work the same on most cars, first of all i would play around with the Hazard warning light switch as the flasher circuit actually goes through that...sometimes they stick a bit and cause problems with the indicator, but by what you say it prob works ok on the o/s?, so that means the flasher unit is ok...you say all the lamps work sometimes, it could be the indicator switch, but sounds like some kind of wiring fault on the n/s, l/h, what i would do is disconnect the lamps one at a time, obviously without all the lamps connected the flasher rate will vary, if the front one works and the back one doesn't it will go twice the speed, do what is easiest, disconnect rear one, then connect it back and disconnect front one, as a last resort try disconnecting the repeater,,,,you could also have a problem on a towing socket at back, or immobilizer wiring...but try easy things first, if hazard work ok you can illiminate all all the lamps and wiring...hope this helps..from Fred in Essex. make sure all the right bulbs are fitted.

Hi there, recently bought a corsa c and I'm really pleased with it. Only thing is when I indicate left, inside it goes really quickly but outside nothing happens on any of the three left hand lights. After a few seconds it may slow down to normal and I get an ordinary flash or two on all three bulbs but then it races off again and I get no lights. This isn't happening on the right, only the left. I replaced all three bulbs but no change. I have read about the indicator relay needing replacing but have not come across these specific symptoms so wanted to take some advice before spending money. Also I don't know anyone else with a corsa to check a known working relay. Any advice would be amazing as the mot is fast approaching!

Cheers,

Nick
 

·
Registered
Joined
·
1,479 Posts
Hi Nick if you haven't cured flashers, i found out next to the battery there is a relay box, held down with some screws etc, the flasher unit is under there, big yellow thing at front, there are two coil's inside it, i think one for each side, think you have to play around with the contacts on faulty side coil, or change the unit....Fred in Essex.
 

·
Registered
Joined
·
1,479 Posts
Yes seems pretty common, mine hasn't done it yet, there is a video on U tube about it, Guy finds it in the box next to the battery takes it out takes it to pieces cleans contacts inside and cures it...well you never know your luck i guess....from Fred in Essex.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top