All Corsa Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi,

I've seen similar problems and answers on other threads but none seem to match or solve my problem.

Front driver side indicator is not working and all driver side indicator bulbs flash fast. Firstly I though this must simply be a blown bulb so changed the bulb that wasn't working. This made no difference, the bulb still doesn't illuminate and all other driver side indicator lights flashing fast.

Then I tried cleaning the connection and even switching the driver and passenger bulb holders to see if it was a problem with the holder.

Next I changed the relay which didn't make any difference either.

It's a Corsa c 2001. When I use the hazards, all indicators flash at normal speed apart from the front driver side bulb still doesn't illuminate.

Any idea what might be causing the problem?

Cheers
 

·
Banned
Joined
·
273 Posts
Check connections and clean the indicator on wing. Do a voltage test if possible to all indicators on That side, making sure you have 12v and good earth to any earth points.
Have you swapped the bulb from the other side to double check the new bulb is really ok...
 

·
Banned
Joined
·
147 Posts
If one bulb is not working, for whatever reason,its normal for the others to flash faster.
1)use a multimeter to check you actually have power reaching the bulb holder (Dont forget it will be intermittent.Its working, no its not, yes it is,no its not, yes it is!!)
2)check the bulb holder is earthing to the light fitting/car body properly. use a multimeter to check continuity. Try running a temporary wire from the earth side of the bulbholder to the car body to see if the bulb then works.
3)Check that the replacement bulb,even if new, actually works. Try the bulb in a different location.Swop bulbs around to see if the fault migrates.Its possible the soldered contact on the bottom is too small and not making proper contact:eek:
 
1 - 3 of 3 Posts
Top