All Corsa Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have been trawling the internet but have no difinitive answers.

Can you help?

Here goes....

LPG 1.2 Corsa Van 55 plate.

almost 2 months ago had problem with gas switching from petrol and no heating. Turned out there was no water in the radiator!!
So I topped it up and added some anti-freeze/coolant.
Everything seemed fine. Although engine was a bit noisy for my liking, the oil light was permanently on and had trace of white cream on oil cap.
Today changed oil pressure switch which rectified the oil light.
At the same time decided to flush the cooling system. After adding distilled water and new coolant ran the engine for a while when it got up to temp there was foam coming from the expansion tank. So assumed there were still traces of the flush product so I flushed the system again a few times with water, refilled with distilled water and coolant.
This time no foam but did notice tiny bubbles in the expansion tank and water coming from the exhaust.
I took it for a 20 minute drive on my return there was no little bubbles in the expansion tank but still had small amount of water from exhaust.
There does not seem to be any water in the oil, there was an oily film on the first batch of coolant I flushed out.
NOW, I am wondering if I have a head gasket problem or possibly a water pump issue.
I have bought a bottle of Steel Seal and on the verge of using it but I just want to be sure what the problem is.
Any advice from any one with similar experience. Much appreciated.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Update

Thanks, went out this morning and needed to top up expansion tank. I think it was because I had not put enough in yesterday. Squeezed all the pipes and ended up with little brown bits floating in the expansion tank!! But doesn't appear to be any air blocks, some water is trickling back.
Water is still coming out of exhaust but not excessively and without white smoke.
Still have traces of cream cheese on the cap.
And noisy knocking sound from, not sure where, water pump, alternator or engine.
I will hold off using the steel seal and see how it goes for the next week or so.
I would like to work out where the noise is coming from though......
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
No apparent leaks

Thanks for the advice Vegas.

There does not appear to be any apparent leaks but a bit difficult to tell with all this rain. I will keep an eye on it.

Driving certainly seems to get rid of the cream cheese but still have traces of water from exhaust but probably normal as you say.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top