All Corsa Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
305 Posts
Discussion Starter · #2 ·
Bump!

I don't think the drivers side pin comes 100% up, maybe 90% of the way before it backs down again very very quickly. But manual entry via key, then locking is fine.

Would a low batt cause this?
something faulty with key?
Chip broke?
Faulty lock on door?

The key lets me in manually, lets me start the car (am I right in thinking this wouldn't happen if the 'chip' was broken?)
 

·
Registered
Joined
·
259 Posts
Shaggy this is exact same as mine it is the door lock actuator on the drivers side is gone and doesn't push lock up fully so it rectifies its self and locks as a safety feature, the part is very cheap however it is far from an easy job to fit, I've just accepted mine and manually open drivers and then use key on rest doesn't lose to much time and it still locks car so I wouldn't worry
 

·
Registered
Joined
·
305 Posts
Discussion Starter · #7 · (Edited)
Passenger had grabbed it in time.

I think your right, I've tried to troubleshoot it as best as I can myself without knowing jack and I'm coming to the point I'm sure its the door.

It does sound like it gets a bit stuck.

I really want to fix it though :(

Could it be something that just needs tightening or adjusting?
Could it be something that needs some grease as its sticking?
Or, is it just one piece that's at fault and can be removed?
Can I just pull one of these out of a wrecked corsa at my local scrappy or does it need to be matched/ paired with my car and key?

What makes it hard?
 

·
Registered
Joined
·
114 Posts
Have you checked the actual lock? The catch that holds door closed when you shut it.

May seem strange but brother had a peugeot he got ECU from newer model and had it fitted.
All of a sudden Central Locking didn't work.
Spent a week trouble shooting. In the end we manually closed and opened lock catches and WD40'd them and passenger 1 was the culprit.
Door opened fine with key but no CL due to 1 catch jamming ever so slightly.
 

·
Registered
Joined
·
259 Posts
I think you can just get one from local scrappies and I haven't bothered as I believe may be wrong that the actuator is sat behind the window so it would be a case of possibly having to take out the window mechanism and everything just to get to it which is why I never botered
 

·
Registered
Joined
·
305 Posts
Discussion Starter · #10 · (Edited)
I bought a few TORX screwdrivers today which was enough hassle as didn't take note of sizes, and was going to get inside the door to have a look but its started raining.

I have some WD40 but it's a sealant not a lube as far as I've been told so may not be a good idea for the lock?

But you may be onto something, mine was very grimy the other day as I have been using some WD40 to stop the door hinges squeak. I will give my locking (thing) inside the door a clean now and see what happens.

EDIT, tried some WD40 and cleaning that catch and it still does it, although it got a bit worse until I moved the grime off it.

So maybe its because I need to clean/lube with something else and/or its more into the door locking system itself?
 

·
Registered
Joined
·
20 Posts
central locking fault

Hello all,

When I try and unlock my car now, it unlocks then relocks itself.

Manual Key-entry allows to me get in, then once door open. Allows me to unlock the others with button.

Allows me to lock fine.

Could someone please advise what is at fault?
hi shaggy,i had the same problem with mine.(2001 c.model.)
bought the car a year ago and also got fed up of using the key manually.
bought a new central locking solenoid,around £17,e.bay.its in the drivers door and controls all the doors,boot and petrol locks.was lucky to have an auto electrician in the family who installed it for me!.:thumbs_up::thumbs_up:
 

·
Registered
Joined
·
6 Posts
Bump!

I don't think the drivers side pin comes 100% up, maybe 90% of the way before it backs down again very very quickly. But manual entry via key, then locking is fine.

Would a low batt cause this?
something faulty with key?
Chip broke?
Faulty lock on door?

The key lets me in manually, lets me start the car (am I right in thinking this wouldn't happen if the 'chip' was broken?)
Mine does exactly the same going to look at it today!
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top