All Corsa Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,141 Posts
Discussion Starter · #1 ·
Ok i have a serious problem with my car, while driving home today and as the title says POP went my car, followed by large cloud of what turned out to be steam.

Managed to get it home, sort of worked out while driving that it must be the radiator as my temperature gauge had just gone through the roof.

Got home opened the bonnet, up pours a cloud of steam :(

What has happened is the large pipe from the left hand side of the radiator connected to the engine has split and completely disintergrated.

Ok what i want to know is:

Is there likely to be any more damage to the actual engine due to it running with no radiator for a while (5mins at most)

Or is it a case of leave to cool down, replace pipe, refill water and its fine

HELP ME PLEASE!
 

·
Registered
Joined
·
3,254 Posts
if its just that pipe thats gone i would have fort you could just get another an fill it back up.
 

·
Registered
Joined
·
2,672 Posts
Na doesnt sound too bad mate, get another pipe and stick it on, although i am a bit more concerned that you kept driving it, how hot did the engine get and how long was it hot for?
 

·
Registered
Joined
·
3,995 Posts
If you're worried get it checked out. Shouldn't be too bad. Just change the hose, fill up your water and give it a good run.
 

·
Registered
Joined
·
1,141 Posts
Discussion Starter · #6 ·
Well the thing was i was only 5 minutes from home, so i thought might as well risk taking it all the way back to my house than being stranded by the side of the road for ages.

Cheers for you opinions, im gonna get a new pipe and see how she runs after that, hopefully should be fine :)
 
1 - 6 of 6 Posts
Top