All Corsa Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1,479 Posts
Discussion Starter · #1 ·
Multi Message for Heaters not working etc.

Firstly make sure the water pump is turning and you have water in header tank, if possible top of radiator, dont take the top of the header tank /radiator when hot, if you have to, use a glove and do it in stages, there should be pressure there if the rad cap is working properly. Make sure the temperature gauge is in the normal place, you will prob get more heat out the heater with the engine revving a bit. If the gauge doesn't go up to normal you wont get much heat out of the heater.
If the heater blows out cold air, usually the thermostats stuck open, or the matrix is blocked or an airlock in the heater hoses. feel the heater hoses when the engine is hot, they should both feel the same, if one is hot and one cold the matrix is either blocked or you have an airlock in the hoses. May have to carefully undo the outlet hose, ease it off and let the air out, do it with radiator /header tank cap off. If the Matrix is blocked take both the hoses off and try to flush it out with a garden hose, both ways, Also check under dash see if there is a water valve and its working properly, also check operation of heater controls, look under dash and see there doing what they should, by turning and watching the controls.

If the heater blower doesn't work, check fuses and any relays that it might use, the circuit usually is, ignition feed to fuse, fuse to motor, motor to resistor pack and from resistor pack to switch and switch to earth, so with a circuit tester you can check for power at various points. if the motor only works on fast speed suspect the resistor pack. Test circuit before wasting money on new bits. You can unplug the motor and substitute it with a bulb, if the bulb comes on and varies in brightness with different switch positions suspect the motor is faulty. The two weakest inks are the motor and resistor pack.

If the heater motor sounds noisy it's usually a sign it wants a new motor, they can get clogged up with leaves etc..if you see and signs of anti freeze up under the dash or on the carpet etc, it's either the hoses leaking or more likely the matrix is leaking, which can be a big job. also its worth checking the heater vents, like pour water in the grill in front of the windscreen and it should run out usually behind the front wheels on both sides, if it doesn't the drains are blocked, and some water could find it's way inside the car
Well i hope this helps someone out there from Fred in Essex. 2016.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top