All Corsa Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 1.0 12v 04 plate. with intermittent starting issues. Emissions light flashing in synchrony with noise from throttle body, engine turns over but won't start. Disconnect throttle body, car starts 1st time. Cleaned all earths, added aux earth to ECU, changed battery. Had it checked by mobile mechanic who thought it was moisture ingress in electrics. only code was intermittent P0560. Had it in heated garage 2 weeks. started and ran for 35 miles, fault now returned. Will normally run fine once started and warm, but fault always returns when cold.:confused:
 

·
Registered
Joined
·
9,410 Posts
Have you checked the ECU for signs of damp / corrosion? The early C version had an issue with damp in the ECU - by 04 they weren't so bad but it's still worth checking.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
ECU. *repaired*

Tried all the obvious, cleaning TB, adding earth to ECU, new battery, cleaning all earths and connectors with no luck, finally tried the ridiculous...Put ECU in oven (wife not impressed) for 1.5hrs @ 80 degC. Then airing cupboard (30degC) for 24 hrs. Amazingly problem solved. Starts 1st time every time and runs fine.
Not recommending...but better than spending £400+ on new ECU
 

·
Registered
Joined
·
9,410 Posts
I'm not sure I'd have risked the oven bit - the airing cupboard is where I usually try this sort of caper. Glad it seems to have done the trick.
 
1 - 4 of 4 Posts
Top