All Corsa Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Im in need of help! Jus bought induction kit for my 96 corsa sport, but few days after doin it ive had a orange engine management light come on, ussually when it starts to get hot, anyone else had this prob n kno how to fix it? Otherwise i gotta put it on diagnostics machine at £40 jus to look at it! Thx, CHris
 

·
Premium Member
Joined
·
15,222 Posts
Check the topbuzz website for the paperclip test.

www.topbuzz.co.uk,

Once you have your code post back on here and we can help you further.
Saves you spending £40 on diagnostics.
 

·
Registered
Joined
·
2,198 Posts
Im in need of help! Jus bought induction kit for my 96 corsa sport, but few days after doin it ive had a orange engine management light come on, ussually when it starts to get hot, anyone else had this prob n kno how to fix it? Otherwise i gotta put it on diagnostics machine at £40 jus to look at it! Thx, CHris
Is there any sort of drop in performance or any other noticable effects or is it just the light?
 

·
Registered
Joined
·
2,198 Posts
Yeah drop in performance as well, and random idling revs too, the engine is X14XE
Sounds very much like an Air Flow Meter gone faulty. If not could also be the idle control but my bet is the AFM.
 

·
Registered
Joined
·
43 Posts
got the same engine as me

ok check the plug thats in the induction pipe.

check for chafing on the manifold, and check that the plug is fully plugged in

to do the paper clip test its easy

simpely use a piese of wire to bridge terminals 5+6

then it should look like this



read off the code (engine warning light will flash 12 times at first then it will flash the code) turn off the ignition to end the test

and post it up on here if you can not find out what the code means
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
Brilliant guys cheers for your help!
I did the test got 35, 71 and 92 :s which i work out to be:
Idle stepper motor
Air Temperature Sensor (ATS) (MPi only)
and Camshaft sensor. :eek:
Quite a bit could the induction kit of blown alll these? Or possibly one is broken so the others are playing up...? i.e Air sensor? How much am i looking at? Got MOT comin up quick!
Thx for readin
CHris
 

·
Premium Member
Joined
·
15,222 Posts
It's more likely that one has broken and is confusing the others.
Air temp sensor or Idle control would be my first guesses. Camshaft would be a longshot.
Ask Steve for a link to Novarob, he should be able to get you what you need.
 
1 - 11 of 11 Posts
Top