All Corsa Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Bought my first car ('08 Corsa 1.3) just over a month ago and a couple weeks back the speedometer stopped working properly. Initially, the needle was stuck at 20 mph even when I turned the car off. Then, when I was doing around 30mph it would read as 60 mph and get stuck there and creep up more whenever I turned the car off and drove again.

The fuel gauge and rpm works fine as well as the cig lighter.

A mechanic had a look at it and took the whole instrument cluster out and fiddled around with it and put it back in and it all seemed fine but a few days later I drove over a pot hole and it started playing up again.

It seems like I have no choice but the replace the whole instrument cluster but I was told it was complicated and expensive process as its coded?

Has anyone had a similar experience and solved the issue without replacing it? Or does anyone know where I could get a new one put in and coded? Im based in Birmingham. And what would happen to my milage readings?

Thanks a lot
 

·
Registered
Joined
·
1,480 Posts
Hi there sounds like it wants anew speedo head, whether is comes separate from the rest of the panel i dont know and i dont know if it needs programming, cant see why it should...Fred in Essex.
 

·
Registered
Joined
·
1 Posts
Bought my first car ('08 Corsa 1.3) just over a month ago and a couple weeks back the speedometer stopped working properly. Initially, the needle was stuck at 20 mph even when I turned the car off. Then, when I was doing around 30mph it would read as 60 mph and get stuck there and creep up more whenever I turned the car off and drove again.

The fuel gauge and rpm works fine as well as the cig lighter.

A mechanic had a look at it and took the whole instrument cluster out and fiddled around with it and put it back in and it all seemed fine but a few days later I drove over a pot hole and it started playing up again.

It seems like I have no choice but the replace the whole instrument cluster but I was told it was complicated and expensive process as its coded?

Has anyone had a similar experience and solved the issue without replacing it? Or does anyone know where I could get a new one put in and coded? Im based in Birmingham. And what would happen to my milage readings?

Thanks a lot
Hi everyone! I know this is an old thread but I thought I would post what I found as I also had a problem with my speedo on my Corsa D although the mileage was still going up. I didn't want to fork out for a new dash so I did some research and found a company in Hampshire called Cartronix who repair these! I drove my car to them and they repaired it in about an hour, its been perfect since. I'm so happy and it was a really reasonable price too.
 
1 - 3 of 3 Posts
Top