All Corsa Forum banner

1 - 20 of 39 Posts

·
Registered
Joined
·
801 Posts
Discussion Starter · #1 · (Edited)
Not posted here for awhile...as I've been busy :thumbs_up:

Comments and criticism welcome...

Well I bought the car back in November 06, after starting driving in a 1.2 corsa (which at the time I thought would destroy anything on the roads), I then dropped a 1.6 8v motor in there and ran it around for just under a year.

It was Ecks who posted up some pictures of his Glanza and I instantly knew one of those would be my next car, after sorting out a loan from the parents and looking into a few things I went on my search to find one!

I saw a very tasty, completely standard green one, but on the day I went down it had been sold, the chap mentioned he had another black quadlight coming in later that week....She was standard with a couple of tasteful mods (133bhp)

First picture after I bought her:



Got her home, very eventful drive home, as I've never driven a turbo car and it was quite a step up from a 1.6 n/a corsa. Well really chuffed now she stuck to the road and was happy in how quick she went as standard.

Some pictures of her at home:











Overall I was happy with the car, until I went to the Huddersfield/Leeds meet and saw Gee's car disapeer up the motorway I wanted more power :p - Not to mention increasing my over draft the same week...I also attended a starlet RR, with just an exhaust, filter and running stock boost she threw out a healthy 151 bhp.

Didn't really do much else to the car until a couple of months ago, fitted new HKS Actuator, sard rrfpr, jam racing FCD, braced decat, straight through exhaust - Only a couple of bits and bobs -



Then this happened:



3 pistons, destroyed - No idea how it happened as was running stock boost :(

So I forked out and bought all new rods/pistons/rings and fitted the head back together with the new bits etc, 10 miles down the motorway the bottom end went :( - I took the crank to get reground but the guy said he would have to take off at least 1mm which would leave it very unsafe to drive. I was gutted.

£500 and 2 weeks later I had another 4EFTE engine sat outside my house, this took a matter of days to fit, as it was that month with the rain, but eventually got it in, up and running, sweet as a nut.



Next I bought some clear indicators, really like them, tinted my old orange ones but didn't like it so kept the clears!



I was happy with the car, nice shine to the very old paint, which was a bonus - So I then decided to have the car detailed www.thecarwashguys.co.uk - 7 hours later...

Pics as follows:







Just this past couple of weeks, I've fit the Autobahn fmic, wee red catch can and also cut and meshed me front bumper:

Testing:


All in:


Blue Petaay:


All bolted back up and sealant set:


Car was setup on wednesday 12th September, by Vessey DC in Barnetby, car managed to push out 178 bhp at the fly, running 1 bar of boost 3.1 bar fuel pressure on a sard rising rate regulator.

Spec:

CT9a Turbo @ 1 bar,
HKS Actuator,
Autobahn front mount,
SARD rising rate fuel pressure regulator,
Walbro fuel pump,
JAM Racing fcd,
TEIN coilovers,
Braced s/s decat,
straight through 2.5" exhaust with HKS backbox,
Air filter relocated to behind front bumper.

Have a manual boost controller in the garage, but not had any boost creep as of yet!

I guess next on my list is to get the spare turbo I have hybridized, already have some quotes so will be looking end of this month at getting it sorted! Not to mention my apexi neo coming to brighten up the interior...and to fine tune the fuelling along the rev range.

- Will keep updating this thread as I go along.

Cheers,
stu
 

·
Registered
Joined
·
2,672 Posts
f*ckin sweet mate, one of very few EP82s that i like. Bout time you did a project thread for this. Didnt realise that basically the whole bottom end of the engine shat itself! I thought starbos were pretty reliable, especially it being a toyota. Healthy figure running just a zorst and filter just goes to show how much a difference it makes on a turbo'd car.

Keep it up and keep us posted :thumbs_up:
 

·
Registered
Joined
·
1,141 Posts
Paint work looks fooking amazing, really nice car you have there and i bet it goes some as well :)
 

·
Registered
Joined
·
801 Posts
Discussion Starter · #6 ·
Thanks for comments...

Yes the car goes well, but clutch is now slipping...can't take the power, bearing in mind its done its job over near 17 years !

Will be upgrading to a paddle clutch (**** for traffic) but sticks like **** to a blanket when you put the power down!

Give it another couple of months, new turbo and manifold, and a good setup on the rollers and will be looking to join the 200+ club :D
 

·
Registered
Joined
·
801 Posts
Discussion Starter · #10 ·
Little update:

Been and bought TRD Paddle clutch

- Will be fitting next weekend, hopefully before Japshow

and also this will be arriving! Apexi Neo!



Hoping to get that wired in at the same time, but not setup, have to find a normal fuel pressure regulator instead of the rising rate one I've got at the moment.

Also new exhaust flexi is getting welded into today, so no more blowage :p
 

·
Registered
Joined
·
1,262 Posts
nice car mate, amazing paintwork
 

·
Registered
Joined
·
2,310 Posts
You definatly know yours stuff. I hate these cars but this one i like :thumbs_up:
 

·
Premium Member
Joined
·
15,222 Posts
Get an update on Stu.
 
1 - 20 of 39 Posts
Top