All Corsa Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi Guys ...been on here for help years ago but have forgotten my log in details ..here's what we have this time .
Corsa 1.3 d 57 plate 33000
genuine miles
For the last year or so it's been missing and really sluggish on start up in all weathers . After a bit of driving it would pick up ..tried redex injector cleaner ..no change ..the problem has got steadily worse and some days she just won't pick up at all ..
3 different mechanics have had a look first 1 said it was a loose timing chain
2nd 1said ..very rare for a chain to go at 33000 probably injectors ...3rd thinks it's the turbo as I now can't get it over 50 mph and where previously there were no faults showing and the engine light is not on
The car did lie dormant for almost 2 years in a garage and I purchased it with 14000 on it I've only done 20 k in it in 4 years ...do it's not a car that does lots of miles ...the turbos been taken off but the guy wants to check it first before I go spending £300 on a recon ..
Can anyone advise on my vague symptoms ..? Any more info required I'll try to elaborate
Thanks in advance ..Al
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
Quick update ...Turbo had been changed... running better got her up to 110 mph on the motorway earlier but the turbo doesn't seem to be kicking in till 3000 revs and she's still a bit sluggish till we get up to that level ..been told the CAT was well clogged up and has been cleaned so give it a good rev through the gears for a week or so and the sluggishness should improve ? Any advice please guys ..I'm clueless
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top