All Corsa Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi,

The engine management light has suddenly appeared on my Corsa.

The car when stationary and idling is always at 1200-1500 whereas it use to idle at 900
It also when driving seems to kick back if I don't accelerate but is completely fine if I have my foot on the pedal. I have put redex through the tank and also put an oil additive into the oil from halfords in as suggested by there guys who said it would help but to no prevail.
So maybe hoping somebody may be able to tell, hopefully going to get time to get a diagnostic check on it today so I'll update with codes later on
 

·
Registered
Joined
·
1,479 Posts
Yes you need to do a code test, sounds like you have a code reader, but if you don't you can probably do the pedal test, sounds a bit like the crank sensor to me, but just a guess, try to avoid being a parts fitter, for example if it says MAF sensor, look for an air leak on the the air trunk that sort of thing, if you take things at face value, you will spend a lot of money for nothing.....might be a good idea to note the codes, then erase them and see if they come back, you can create codes buy running it with different plugs disconnected etc, also try leaving the battery disconnected for 1/2, hour, but beware you will loose radio code if it has one.......from Fred in Essex.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top